Close

Bugs

Boyko
6 years ago
#3117 Quote
Avatar
  • Moderator
  • 1437
Thilak wrote:
Hi Boyko,
                     Thank you very much for your response.

I changed the global.asax file
I used nopcommerce 3.0 .I downloaded it from the official website only with source code
how can i overcome this error ?


Hi Thilak,

Please send us an email with your web site credentials to support at nop-templates.com email and we will take a look at what could be wrong with your installation.

Thanks
Regards,
Boyko Stanev
Nop-Templates.com
katie366
6 years ago
#3352 Quote
Avatar
  • 1
I am trying to W3C Validate my website, and I am getting an error on the mega menu because of a blank src attribute on the image. "Bad value for attribute src on element img: Must be non-empty." Is there anyway round this?
Thanks
Boyko
6 years ago
#3353 Quote
Avatar
  • Moderator
  • 1437
katie366 wrote:
I am trying to W3C Validate my website, and I am getting an error on the mega menu because of a blank src attribute on the image. "Bad value for attribute src on element img: Must be non-empty." Is there anyway round this?
Thanks


Hi katie366,

Thank you for reporting this!
The problem is because we use lazy loading of the images in the Mega Menu and load them on hover. So this will actually never be empty but it is initially. This is a very good optimization for faster page load and especially when you have too many images in the Mega Menu.
There is a very quick fix for this, which we will add in the official package. Please let me know, which version of the plugin (theme) do you use, so that I can tell you how to update or apply the fix directly in the Razor view file.

Thanks
Regards,
Boyko Stanev
Nop-Templates.com
Support
6 years ago
#3354 Quote
Avatar
  • Moderator
  • 1002
Boyko wrote:
I am trying to W3C Validate my website, and I am getting an error on the mega menu because of a blank src attribute on the image. "Bad value for attribute src on element img: Must be non-empty." Is there anyway round this?
Thanks

Hi katie366,

Thank you for reporting this!
The problem is because we use lazy loading of the images in the Mega Menu and load them on hover. So this will actually never be empty but it is initially. This is a very good optimization for faster page load and especially when you have too many images in the Mega Menu.
There is a very quick fix for this, which we will add in the official package. Please let me know, which version of the plugin (theme) do you use, so that I can tell you how to update or apply the fix directly in the Razor view file.

Thanks


Hi katie366,

We have fixed the issue and deployed it on our website. You can download the theme again from your My Downloads section and either update only the Nop Mega Menu plugin (according to this article) or better update the whole theme as there might be some bug fixes included. (according to this article)

If you have any queries please do not hesitate to contact us again.
LMOS
5 years ago
#4102 Quote
Avatar
  • 3
When i add a new category in the admin and un-check "Include in top menu:" it still shows up on the top mega menu
gnik
5 years ago
#4463 Quote
Avatar
  • 41
Hi. MegaMenu does not work with multiple stores.
Boyko
5 years ago
#4464 Quote
Avatar
  • Moderator
  • 1437
gnikspam wrote:
Hi. MegaMenu does not work with multiple stores.


Hi gnikspam,

Which version of the Mega Menu are you using? What exactly is not working for you with multiple stores? Please provide more information.

Thanks
Regards,
Boyko Stanev
Nop-Templates.com
LMOS
5 years ago
#4465 Quote
Avatar
  • 3
When i add a new category in the admin and un-check "Include in top menu:" it still shows up on the top mega menu
Deni
5 years ago
#4469 Quote
Avatar
  • Moderator
  • 389
LMOS wrote:
When i add a new category in the admin and un-check "Include in top menu:" it still shows up on the top mega menu


Hi, LMOS !

The setting "Include in top menu:" is working only with the default nopCommerce menu. Our MegaMenu plug-in has nothing with it and its settings. The plug-in has setting "Display only top level categories, which are marked as 'Show on home page':" which you can use.
Best Regards,
Mladen Staykov
Nop-Templates.com
gnik
5 years ago
#4470 Quote
Avatar
  • 41
Boyko wrote:
Hi. MegaMenu does not work with multiple stores.

Hi gnikspam,

Which version of the Mega Menu are you using? What exactly is not working for you with multiple stores? Please provide more information.

Thanks


I use NopUltimatePluginCollection 3.21
put the menu for one store, the menu is automatically put in the shop 2. I nehochu menu that would work in the store 2.
Thank you.