Close

Bugs

Support
6 years ago
#1226 Quote
Avatar
  • Moderator
  • 1002
PM
Please write here if you have any problems with the Nop Mega Menu Plugin
vedran
6 years ago
#1232 Quote
Avatar
  • 45
PM
In Internet explorer 9, menu is transparent. Please see Mushroomslook
Support
6 years ago
#1236 Quote
Avatar
  • Moderator
  • 1002
PM
Hi,

Thank you for reporting this!
We are going to fix this and will let you know how you can update your plugin installation.

Best Regards
Support
6 years ago
#1238 Quote
Avatar
  • Moderator
  • 1002
PM
vedran wrote:
In Internet explorer 9, menu is transparent. Please see Mushroomslook


Hi vedran,

This is fixed now. Please download the latest package and update the css for the mega menu plugin.

Thank you again for reporting this!

Best Regards,
Nop-Templates Support Team
CorsaMeccanica
6 years ago
#1285 Quote
Avatar
  • 17
PM
Hello,

I have incorporated the Mega Menu into my company's website, the website is in development on a test domain to a specific port (example.com:8080). The mega menu seems to work great, except after several hours time the category images within the menu system disappear and show the browsers default symbol for a broken image link.

I have IIS and SQL pretty well set at defaults with the exception of a couple things. Notably I do not have any compression or caching settings on that I am aware of that would interfere with this.

I also have images of this happening to the menu system in Firefox and Google chrome if your interested in seeing those. If you need access to my domain/ web root and server to assess this bug please let me know via email.
IvanStoyanov
6 years ago
#1295 Quote
Avatar
  • Moderator
  • 269
PM
shanexh wrote:
Hello,

I have incorporated the Mega Menu into my company's website, the website is in development on a test domain to a specific port (example.com:8080). The mega menu seems to work great, except after several hours time the category images within the menu system disappear and show the browsers default symbol for a broken image link.

I have IIS and SQL pretty well set at defaults with the exception of a couple things. Notably I do not have any compression or caching settings on that I am aware of that would interfere with this.

I also have images of this happening to the menu system in Firefox and Google chrome if your interested in seeing those. If you need access to my domain/ web root and server to assess this bug please let me know via email.


Hello shanexh,

We have sent you an email, asking for screenshots and/or acces to your server, in order to investigate the problem.
We are still waiting for an answer.

Have a great day!

Ivan Stoyanov
Thank you for choosing our products! Your feedback is important to us!
CorsaMeccanica
6 years ago
#1298 Quote
Avatar
  • 17
PM
IvanStoyanov wrote:


Hello shanexh,

We have sent you an email, asking for screenshots and/or acces to your server, in order to investigate the problem.
We are still waiting for an answer.

Have a great day!

Ivan Stoyanov


I have replied to your email with all the info you should need. I would have earlier, but it went to my junk mail (I added your support account to my contacts so it won't happen again).
incredible
6 years ago
#1476 Quote
Avatar
  • 5
PM
I have added the Mega Menu folders to the plugins folder as per the instructions. Now I get an error when tring to go to the admin of my site. I have tried to delete the plugins from the folder but the same error occurs. I have also tried deleting the sttings.txt in APP_DATA directory but this does not work either, please could you help. The site is on my local:32686 Thanks, Mark

Server Error in '/' Application.
--------------------------------------------------------------------------------

A plugin with 'SevenSpikes.Core' system name is already defined
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Exception: A plugin with 'SevenSpikes.Core' system name is already defined

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace:


[Exception: A plugin with 'SevenSpikes.Core' system name is already defined]
   Nop.Core.Plugins.PluginManager.Initialize() +1957

[Exception: A plugin with 'SevenSpikes.Core' system name is already defined
]
   Nop.Core.Plugins.PluginManager.Initialize() +2202

[InvalidOperationException: The pre-application start initialization method Initialize on type Nop.Core.Plugins.PluginManager threw an exception with the following error message: A plugin with 'SevenSpikes.Core' system name is already defined
.]
   System.Web.Compilation.BuildManager.InvokePreStartInitMethods(ICollection`1 methods) +423
   System.Web.Compilation.BuildManager.CallPreStartInitMethods() +306
   System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException) +677

[HttpException (0x80004005): The pre-application start initialization method Initialize on type Nop.Core.Plugins.PluginManager threw an exception with the following error message: A plugin with 'SevenSpikes.Core' system name is already defined
.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9090876
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +97
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +256


CorsaMeccanica
6 years ago
#1477 Quote
Avatar
  • 17
PM
Hello,

When I include manufacturers in the Mega Menu it doesn't change the title of this menu when I edit it in the manufacturers menu settings. It won't change it even when I try to edit the value in settings.xml directly.

a solution to this would be appreciated. Otherwise I will work around it manually.

Regards,

Shane.
Boyko
6 years ago
#1478 Quote
Avatar
  • Moderator
  • 1436
PM
incredible wrote:
I have added the Mega Menu folders to the plugins folder as per the instructions. Now I get an error when tring to go to the admin of my site. I have tried to delete the plugins from the folder but the same error occurs. I have also tried deleting the sttings.txt in APP_DATA directory but this does not work either, please could you help. The site is on my local:32686 Thanks, Mark

A plugin with 'SevenSpikes.Core' system name is already defined
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Exception: A plugin with 'SevenSpikes.Core' system name is already defined


Hi incredible,

It seems that you have the Core plugin folder more than once in your Plugins folder.
Please make sure you have the SevenSpikes.Core plugin folder only once in your nopCommerce Plugins folder.
It is not a good idea to delete the Settings.txt file as it contains the database connection string.

Best Regards,
Nop-Templates Support Team
Regards,
Boyko Stanev
Nop-Templates.com