Close

Nop 3.5 - After I install the plugins, the site is slow and always presenting "Application started" in the log

uiskas2
5 years ago
#8561 Quote
Avatar
  • 1
Hi.

I'm Pedro, and I need help.

Every time the site is fine and suddenly slows down, I don't know what happened, I tried debug and I don't found errors or slowing.

I have in log only "Application started", I have one or twice this information in 10 minutes.

I think that the problem is something in the session, because when I try to start manually the Keep Alive the site is down, sending 503 error

Did someone had the same situation or something like this?

Thank you for your attention.
Boyko
5 years ago
#8564 Quote
Avatar
  • Moderator
  • 1497
uiskas2 wrote:
Hi.

I'm Pedro, and I need help.

Every time the site is fine and suddenly slows down, I don't know what happened, I tried debug and I don't found errors or slowing.

I have in log only "Application started", I have one or twice this information in 10 minutes.

I think that the problem is something in the session, because when I try to start manually the Keep Alive the site is down, sending 503 error

Did someone had the same situation or something like this?

Thank you for your attention.


Happy New Year, Pedro!

You should contact your hosting provider and ask them to increase the memory limit of your web site.
Usually they set memory limit to your web site's application pool and once your web site reach this limit then the application pool and your web site respectively is restarted automatically.

Please don't duplicate posts and tickets!
Regards,
Boyko Stanev
Nop-Templates.com
RonM
4 years ago
#10158 Quote
Avatar
  • 7
Let me guess. Your hosting provider is Arvi$$?  Good luck with them. I had same issues, and never got NopCommerce to work with Nop-Templates plugins installed with their hosting plans even after upgrading my plan. They refused to increase app pool memory to needed level even with their best hosting plan. Would have to go to VPS plan to get required app pool memory (they tried to upsell me to VPS after all else failed). Lots of $$$ for that (like $250 per month to start!!!).  Now I host all my nopcommerce sites on MY OWN SERVERS (I have a rack of 8 servers). I figured that I would rather invest in my own equipment than pay for VPS from a provider, since I am a certified network engineer, and a Bizspark Partner.  Invested over $30K in equipment, and now have my own hosting business. rlmec.us. My servers have plenty of horsepower and bandwidth to run about 500 nopcommerce sites WITH ALL NOP-TEMPLATES INSTALLED! WE SPECIALIZE IN NOPCOMMERCE HOSTING.  Also offer Azure hosting if desired. One way or another, you will need to find a provider who will give you adequate app pool memory.
botman86
4 years ago
#12296 Quote
Avatar
  • 5
We have a similar issue With nop 3.6 and Urban Theme.
We are on a dedicated server and Application Pool Recycle time is 1740 minutes. No limits on memory.

Application started every 20 seconds.

How can we resolve the problem?

we have also opened a ticket with you about this.

hristian.dimov
4 years ago
#12301 Quote
Avatar
  • Moderator
  • 386
botman86 wrote:
We have a similar issue With nop 3.6 and Urban Theme.
We are on a dedicated server and Application Pool Recycle time is 1740 minutes. No limits on memory.

Application started every 20 seconds.

How can we resolve the problem?

we have also opened a ticket with you about this.



Hi,

In the ticket discussion, you have said that you have changed the "Maximum number of worker processes" from 15 to 1, which fixed your issue. Only if you are using web gardens, you need it to be more than 1. But as in nopCommerce 3.60, you do no have distributed cache or support for web gardens you should have it set to 1 worker process.

Hope this helps!
Regards,
Hristian Dimov
Nop-Templates.com