Close

Carousel3DSettings_Slider issue on upgrade to 3.3

jdyer
3 years ago
#7524 Quote
Avatar
  • 5
PM
I have run the upgrade script against database. So far, only plugin issue I have is when trying to Install Nop Anywhere Sliders I get the following error: "There is already an object named 'Carousel3DSettings_SLider' in the database. Could not create constraint. See previous errors. "
All other plugins reloaded.
Thank you.
Deni
3 years ago
#7536 Quote
Avatar
  • Moderator
  • 389
PM
jdyer wrote:
I have run the upgrade script against database. So far, only plugin issue I have is when trying to Install Nop Anywhere Sliders I get the following error: "There is already an object named 'Carousel3DSettings_SLider' in the database. Could not create constraint. See previous errors. "
All other plugins reloaded.
Thank you.


Hello,

From which version do you started upgrading? In the last two versions of nopCommerce we do not have such object: 'Carousel3DSettings_SLider'.

Please provide us more information, so we can be able to help you.

Best Regards !
Best Regards,
Mladen Staykov
Nop-Templates.com
jdyer
3 years ago
#7537 Quote
Avatar
  • 5
PM
2.7
Boyko
3 years ago
#7545 Quote
Avatar
  • Moderator
  • 1385
PM
jdyer wrote:
2.7


Hi jdyer,

Have you run all the upgrade scripts in this order 2.7 -> 2.8, 2.8 -> 3.0, ... 3.2 -> 3.3?
Did you have the Sliders installed in 2.7 before the upgrade?
If so then you should have them already installed and you don't have to install them again.
If you haven't had the Sliders installed then there should be any tables in the database related to the Sliders. Actually as Deni described this table is no more used since version 3.1 and the installation of the Sliders are no more looking for it. Are you sure that you are suing the 3.3 version of the Sliders when you try to install them or you have modified the supported version in the Description.txt file of the Sliders plugin?

Thanks
Regards,
Boyko Stanev
Nop-Templates.com
jdyer
3 years ago
#7877 Quote
Avatar
  • 5
PM
Thank you for your response.  I had not run all your upgrade scripts for each version in between version 2.7 through 3.3. After doing that all is well! Thank you again!
flark
2 years ago
#9300 Quote
Avatar
  • 1
PM
I've upgraded a clients site from nop 2.65 to 3.5. She did not have the files for the site, only the database.
On attempting to install this plugin I am receiving the same error as above and would like to know how to correct this. I have run each upgrade script incrementally but the error persists.

Any help would be very much appreciated!
iliyan.tanev
2 years ago
#9307 Quote
Avatar
  • Moderator
  • 347
PM
Hi,

Did we send the upgrade scripts to you, because we are shipping only for the last three version of nopCommerce ? If we didn't send you the upgrade scripts could you open a ticket and we will send them to you.
Regards,
Iliyan Tanev
Nop-Templates Dev Team