Close

Nop Ajax Filters not showing on search engine, Nop 4.2

Efraingoyz
27 days ago
#16014 Quote
Avatar
  • 6
I've been having problems getting ajax filters to show up on search engine. We recently upgraded to Nop 4.2 and ever since, I can't get Ajax Filters to show up. When we were running Nop 4.1, all I had to do was enable the setting from the Admin site and that did the trick. Now I have that setting enabled and I can see the div when I inspect the search page but the div itself is empty.
Any help on this? Is this a known bug?

I've got product attributes that I'd like to display on search page. Setting is enabled under Integration Settings.
SDobrev
25 days ago
#16025 Quote
Avatar
  • Moderator
  • 269
Hi,

Could you please submit a ticket providing more details (URL to the store, if it is possible admin credentials) about this issue?

Thank you!
Best Regards,
Stoyan Dobrev
Nop-Templates.com
Efraingoyz
24 days ago
#16029 Quote
Avatar
  • 6
Hi,

I can't provide admin credentials, I'd have to speak with my manager. We use Office365 auth to log in/out. There's no 'admin' credentials per say.

The website itself is https://orders.wirelesszone.com, if you search for Airpods, then inspect the filter column, you'll see what I'm referring to. You can also go under Accessories, which is where the AjaxFilter does show up. If there's anything else you need, pictures of all the Integration Settings, or anything else. Please let me know.
SDobrev
24 days ago
#16030 Quote
Avatar
  • Moderator
  • 269
Hi,

Check which filter panels are enabled in the Ajax Filters settings and if the products returned by the search engine can be filtered by these filter panels.
Best Regards,
Stoyan Dobrev
Nop-Templates.com
Efraingoyz
24 days ago
#16031 Quote
Avatar
  • 6


You can see the integration settings. If you go to the site mentioned, and search under accessories, you'll see plenty of product attributes under Compatibility, which is what I'm searching for, yet it doesn't show under the search engine filters.
Efraingoyz
24 days ago
#16032 Quote
Avatar
  • 6
https://imgur.com/a/xMtNgqv

Link didn't show first time..
SDobrev
24 days ago
#16033 Quote
Avatar
  • Moderator
  • 269
Hi,

It looks like there aren't any available filters for these products. You can try to enable all filters from the "Ajax Filters Availability Settings" tab.

Unfortunately, without access to the administration, we can't give you any other suggestions.
Best Regards,
Stoyan Dobrev
Nop-Templates.com
Efraingoyz
23 days ago
#16035 Quote
Avatar
  • 6
Here are my availability settings, the product attributes fall under 'Enable Attributes Filter'
https://imgur.com/a/wSpzjrk

And here's an example of the filters working like they're supposed to on the catalog page

https://imgur.com/a/X3vq2EF

And here's what it looks like on the search page when you inspect the elements. Those products that I searched for have product attributes assigned to them.

https://imgur.com/a/F3XqKO8

If you can walk me through what you'd check if you were logged in as an admin, that'd be at least helpful.
SDobrev
22 days ago
#16043 Quote
Avatar
  • Moderator
  • 269
Hi,

If it is possible to send us your current database we will debug the code locally and find the problem.
Best Regards,
Stoyan Dobrev
Nop-Templates.com
Efraingoyz
15 days ago
#16083 Quote
Avatar
  • 6
SDobrev,

Working on getting you access to our Nop dev environment. I'll PM you once I get those credentials.