Close

Errors after update to 4.3

Damir
3 years ago
#21162 Quote
Avatar
  • 27
Hi,
I have lots of problems with v4.3 upgrade. First, after the installation nothing worked, the site was crashing immediately with different SQL errors. After a while I deleted all instances of SevenSpikes plugins from plugins.json file and the system woke up without problems. Then I've deleted all SevenSpikes plugins and theme files, downloaded latest versions of everything and instaled the theme and plugins again.
That went well, so I've restarted the application and activated the theme. It all went ok, but the MegaMenu wasn't there. Just ugly gray standard meny is visible. I went to admin and into Menu setting, my old meny is stil there, but I get error saying "NullReferenceException: Object reference not set to an instance of an object." and it all dies on me.
It's really weird, same with rich blog plugin, when I click on menu item for blog, it craches with unhandled exception, "InvalidOperationException: Sequence contains more than one matching element"

Do you have any ideas why it is happening? The site is at: https://staging.balkanexcellence.com/

I have well functioning v4.2 at https://balkanexcellence.com/ but the upgrade didn't really work with your theme/plugins. Btw, there might me many more errors, I've just haven't had time to test everything yet.
Boyko
3 years ago
#21165 Quote
Avatar
  • Moderator
  • 1570
Damir wrote:
Hi,
I have lots of problems with v4.3 upgrade ...


Hi Damir,

It would be best to submit a ticket and provide access to your store administration so that we can investigate and advise.
Many of our clients already upgraded to nopCommerce 4.30 without any problems so it must be something you might have missed in the upgrade process but of course we can check that too.
Make sure you are using the very latest packages from our website and you also use the very latest version of nopCommerce 4.30 (the one released later)
Regards,
Nop-Templates.com Team
ASouth
11 months ago
#22138 Quote
Avatar
  • 1
I am having the same Mega Menu error after upgrading to 4.6, what was the solution to this?