Close

Problem adding languages to Nop

ceejay34
4 years ago
#9324 Quote
Avatar
  • 13
Ive installed an extra language, german. Now i get sevenspikes placeholders in several places, the footer menu when using quickview etc.


I know i can add these by hand but can i somehow uninstall and reinstall all the plugins so the system makes these entries in the database for my added language?
See http://shop.aimeefashion.nl and click german or english flags. Yes english has the problem too.
Boyko
4 years ago
#9326 Quote
Avatar
  • Moderator
  • 1437
ceejay34 wrote:
Ive installed an extra language, german. Now i get sevenspikes placeholders in several places, the footer menu when using quickview etc.


I know i can add these by hand but can i somehow uninstall and reinstall all the plugins so the system makes these entries in the database for my added language?
See http://shop.aimeefashion.nl and click german or english flags. Yes english has the problem too.


Hi ceejay34,

If there are no language specific resource files for a given plugin then the plugin adds the English resources for all active languages on startup.
This is true for all our plugins.
So you just need to restart the application when you add a new language and you will have all the necessary resources installed for all plugins.
I don't see any missing resources in your web site.
Regards,
Boyko Stanev
Nop-Templates.com
ceejay34
4 years ago
#9328 Quote
Avatar
  • 13
That works for english being added. However i added german language pack and tried to restart the application and the store crashed. I had to restore the database.

I have a guess: the xml file for german is somehow corrupt. I looked and nobody complained about it. The end of the file has fields neatly closed. i didnt see a problem.

However i added 2 published languages before restarting the application, is that what caused the crash do you think? Im hesitant to try again if i think it will crash again.
Boyko
4 years ago
#9333 Quote
Avatar
  • Moderator
  • 1437
ceejay34 wrote:
That works for english being added. However i added german language pack and tried to restart the application and the store crashed. I had to restore the database.

I have a guess: the xml file for german is somehow corrupt. I looked and nobody complained about it. The end of the file has fields neatly closed. i didnt see a problem.

However i added 2 published languages before restarting the application, is that what caused the crash do you think? Im hesitant to try again if i think it will crash again.


Hi ceejay34,

I am referring to the resources of our products. Each plugin has Resources folder and it contains the resources required for the given plugin. I am not talking about the general resources in nopCommerce. It is possible that there might be some problems with the german language pack or any other language packs but you need to contact the vendor of these language packs and ask them to fix these issues.
Regards,
Boyko Stanev
Nop-Templates.com