Close

Profile: codicezerouno

Avatar

User posts

4 years ago

Hi Stanev,
problem solved after updating with latest binaries.

This means that the version "3.6.426.16755" of "Core" plugin, I was using before, causes the error.

Thanks

4 years ago

Hi,
I double check it and all files are on the folders.

I tried to upload to an other server and I got the same error.

Is there some special setup I need to do into IIS?

Thanks and Regards

4 years ago

I got the error in a clean nop installation without any other plugin except those provided with nop binaries.
So, I supposed that anyone changed the route you mentioned.

The strange thing is that the error is not thrown if the project runs in Visualstudio.

4 years ago

I tried to install Sevenspikes.core plugin in a clean nop 3.60, but after that the site throws the error

4 years ago

Hi,
there are some changes on nop source code but the project runs successfully on dev environement

4 years ago

Hello,
I would need to run a new color.

I can, in some way, add a new color from the administrative panel?
thanks

4 years ago

Additional info:
if I remove all sevenspikes folders in plugin folder, the site runs up without error.
As soon as I deploy the Sevenspikes.Core folder the site throws the error I posted before.

It seems related to Sevenspikes.Core plugin

4 years ago

Hello,
I deployed a site with this theme installed. the site is running locally but the copy running on the server throws this error:


[NullReferenceException: Object reference not set to an instance of an object.]
   SevenSpikes.Nop.Framework.Routing.BaseRouteProvider.A4TgU82qDF(IViewEngine7Spikes  ) +69
   SevenSpikes.Nop.Framework.Routing.BaseRouteProvider.RegisterRoutes(RouteCollection routes) +206
   Nop.Web.Framework.Mvc.Routes.<>c__DisplayClass3_0.<RegisterRoutes>b__1(IRouteProvider rp) in C:\Lavoro\iDeal.Site\nopCommerce\Presentation\Nop.Web.Framework\Mvc\Routes\RoutePublisher.cs:67
   System.Collections.Generic.List`1.ForEach(Action`1 action) +118
   Nop.Web.Framework.Mvc.Routes.RoutePublisher.RegisterRoutes(RouteCollection routes) in C:\Lavoro\iDeal.Site\nopCommerce\Presentation\Nop.Web.Framework\Mvc\Routes\RoutePublisher.cs:67
   Nop.Web.MvcApplication.RegisterRoutes(RouteCollection routes) in C:\Lavoro\iDeal.Site\nopCommerce\Presentation\Nop.Web\Global.asax.cs:34
   Nop.Web.MvcApplication.Application_Start() in C:\Lavoro\iDeal.Site\nopCommerce\Presentation\Nop.Web\Global.asax.cs:63




[HttpException (0x80004005): Object reference not set to an instance of an object.]
   System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +588
   System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +181
   System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +320
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +389
   System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +409




[HttpException (0x80004005): Object reference not set to an instance of an object.]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +646
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +99
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +669


Please, can you give an idea on how to solve it?

4 years ago

Hi, I have a running project on nop 3.50. Is it possible to have richblog for that version?

5 years ago

solution found: http://www.nop-templates.com/boards/topic/2/bugs/page/6#2698

tnx